站点图标 陌路寒暄

搜索进阶题目之A Knight's Journey

搜索进阶题目之A Knight's Journey

时间: 1ms        内存:128M

描述:


The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?




输入:


The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

输出:


The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

示例输入:

3
1 1
2 3
4 3

示例输出:

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

提示:

参考答案(内存最优[1092]):

#include <stdio.h>
#include <stdlib.h>
#define MAX 27
int map[MAX][MAX], sx[MAX], sy[MAX];
int dir[8][2] = {{-2, -1}, {-2, 1}, {-1, -2}, {-1, 2},{1, -2}, {1, 2}, {2, -1}, {2, 1}};
int p, q, sign, step;
void dfs(int i, int j)
{
    if (sign) return;
    int x, y, k;
    step++;
    sx[step] = i;
    sy[step] = j;
    if(step == p * q)
    {
        sign = 1;
        return;
    }
    map[i][j] = 1;
    for (k = 0; k < 8; k++)
    {
        y = j + dir[k][0];
        x = i + dir[k][1];
        if (map[x][y] == 0 && x > 0 && x <= p && y > 0 && y <= q)
        {
            dfs(x, y);
            step--;
        }
    }
    map[i][j] = 0;
}

int main()
{
    int i, j, n, t = 0;
    scanf("%d", &n);
    while(n--)
    {
        sign = 0;
        step = 0;
        t++;
        scanf("%d%d", &p, &q);
        for (i = 1; i <= p; i++)
        {
            for(j = 1; j <= q; j++)
            {
                map[i][j] = 0;
            }
        }
        dfs(1, 1);
        printf("Scenario #%d:\n", t);
        if (sign)
        {
            for (i = 1; i <= p * q; i++)
            {
                printf("%c%d", sy[i] + 64, sx[i]);
            }
            printf("\n");
        }
        else
        {
            printf("impossible\n");
        }
        if (n != 0) printf("\n");
    }
    return 0;
}

参考答案(时间最优[4]):

#include<cstdio>
#include<cstring>
int n,m,nm;
bool map1[15][15],flag;
int dir[8][2]={{-1,-2},{1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
struct node
{
    int x,y;
}record[15][15];
char ans[50]="A1";
void DFS(int x,int y,int step)
{
    if(step==nm)
    {
        ans[step*2]='\0';
        flag=true;
        return;
    }
    int tx,ty;
    for(int i=0;i<8;i++)
    {
        tx=x+dir[i][0];
        ty=y+dir[i][1];
        if(tx<0||ty<0||tx>=n||ty>=m)
            continue;
        if(map1[tx][ty])
        {
            ans[step*2]=ty+65;
            ans[step*2+1]=tx+49;
            map1[tx][ty]=false;
            record[tx][ty].x=x;
            record[tx][ty].y=y;
            DFS(tx,ty,step+1);
            if(flag)
                return;
            map1[tx][ty]=true;

        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int i=1;i<=t;i++)
    {
        scanf("%d%d",&n,&m);
        memset(map1,true,sizeof(map1));
        nm=n*m;
        flag=false;
        map1[0][0]=false;
        printf("Scenario #%d:\n",i);
        DFS(0,0,1);
        if(flag)
            printf("%s\n\n",ans);
        else
            printf("impossible\n\n");
    }
    return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版