站点图标 陌路寒暄

Buildings

Buildings

时间: 1ms        内存:128M

描述:

 Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.

  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.

  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.

  Each floor has its own weight wi and strength si. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σwj)-si, where (Σwj) stands for sum of weight of all floors above.

  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.

  Now, it’s up to you to calculate this value.

输入:

 There’re several test cases.
In each test case, in the first line is a single integer N (1 <= N <= 105) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers wi and si (0 <= wi, si <= 100000) separated by single spaces.
Please process until EOF (End Of File).

输出:

For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.

  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.

示例输入:

3
10 6
2 3
5 4
2
2 2
2 2
3
10 3
2 5
3 3

示例输出:

1
0
2

提示:

参考答案(内存最优[0]):

#include<stdio.h>
#include<stdlib.h>
#define LL long long
#define max(a,b) ((a)>(b)?(a):(b))
struct floor
{
    int w,s;
} node[100005];
int cmp(const void *a,const void *b)
{
    struct floor *c=(struct floor *)a;
    struct floor *d=(struct floor *)b;
    return (c->w+c->s) - (d->w+d->s);
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        int i;
        for( i=0; i<n; ++i)
            scanf("%d%d",&node[i].w,&node[i].s);
        qsort(node,n,sizeof(struct floor),cmp);
        LL summ=0,maxx=0;
        for( i=0; i<n; ++i)
        {
            maxx=max(maxx,summ-node[i].s);
            summ+=node[i].w;
        }
        printf("%lld\n",maxx);
    }
    return 0;
}

参考答案(时间最优[0]):

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long
struct point
{
    int w,s;
} node[100005];
int n;
bool cmp(const point &a,const point &b)
{
    return a.w+a.s<b.w+b.s;
}
int main()
{
    for(; ~scanf("%d",&n);)
    {
        for(int i=0; i<n; ++i)
            scanf("%d%d",&node[i].w,&node[i].s);
        sort(node,node+n,cmp);
        LL summ=0,maxx=0;
        for(int i=0; i<n; ++i)
        {
            maxx=max(maxx,summ-node[i].s);
            summ+=node[i].w;
        }
        printf("%lld\n",maxx);
    }
    return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版