站点图标 陌路寒暄

Lowest Bit

Lowest Bit

时间: 1ms        内存:64M

描述:

Given an positive integer A (1 <= A <= 100), output the lowest bit of A. For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2. Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

输入:

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

输出:

For each A in the input, output a line containing only its lowest bit.

示例输入:

26
88
0

示例输出:

2
8

提示:

参考答案(内存最优[748]):

#include<stdio.h>
int main()
{
	int a;
	while(scanf("%d",&a)==1&&a!=0){
		int b[7];
		int i=0;
		do{
			if(a/2==0)break;
			b[i++]=a%2;
			a=a/2;
		}while(a/2);
		b[i]=a%2;
		int j=0;
		for(j;j<=i;j++){
		if(b[j]!=0)break;
		}	
		int sum=1;
		for(i=0;i<j;i++){
		sum*=2;
		}
		printf("%d\n",sum);
	
	}
return 0;
}

参考答案(时间最优[0]):

#include<stdio.h>
int main()
{
	int a;
	while(scanf("%d",&a)==1&&a!=0){
		int b[7];
		int i=0;
		do{
			if(a/2==0)break;
			b[i++]=a%2;
			a=a/2;
		}while(a/2);
		b[i]=a%2;
		int j=0;
		for(j;j<=i;j++){
		if(b[j]!=0)break;
		}	
		int sum=1;
		for(i=0;i<j;i++){
		sum*=2;
		}
		printf("%d\n",sum);
	
	}
return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版