站点图标 陌路寒暄

Fibonacci Again

Fibonacci Again

时间: 1ms        内存:64M

描述:

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2)

输入:

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000)

输出:

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

示例输入:

0
1
2
3
4
5

示例输出:

no
no
yes
no
no
no

提示:

参考答案(内存最优[964]):

#include<stdio.h>
int main()
{
 int n;
 while(scanf("%d",&n)!=EOF)
 {
  if(n>=100) n=n%100;
  if(n%4==2) printf("yes\n");
  else  printf("no\n");
 }
 return 0;
}

参考答案(时间最优[0]):

#include<stdio.h>
int main()
{
 int n;
 while(scanf("%d",&n)!=EOF)
 {
  if(n>=100) n=n%100;
  if(n%4==2) printf("yes\n");
  else  printf("no\n");
 }
 return 0;
}

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版