站点图标 陌路寒暄

Friends number

Friends number

时间: 1ms        内存:128M

描述:

Paula and Tai are couple. There are many stories between them. The day Paula left by airplane, Tai send one message to telephone 2200284, then, everything is changing… (The story in “the snow queen”).

After a long time, Tai tells Paula, the number 220 and 284 is a couple of friends number, as they are special, all divisors of 220’s sum is 284, and all divisors of 284’s sum is 220. Can you find out there are how many couples of friends number less than 10,000. Then, how about 100,000, 200,000 and so on.

The task for you is to find out there are how many couples of friends number in given closed interval [a,b]。

输入:

There are several cases.

Each test case contains two positive integers a, b(1<= a <= b <=5,000,000).

Proceed to the end of file.

输出:

For each test case, output the number of couples in the given range. The output of one test case occupied exactly one line.

示例输入:

1 100
1 1000

示例输出:

0
1

提示:

参考答案(内存最优[800]):

#include<stdio.h>

int fn[30][2]={

	220,284,

	1184,1210,

	2620,2924,

	5020,5564,

	

	6232,6368,

	10744,10856,

	12285,14595,

	17296,18416,

	

	63020,76084,

	66928,66992,

	67095,71145,

	69615,87633,

	

	79750,88730,

	100485,124155,

	122265,139815,

	

	122368,123152,

	141664,153176,

	142310,168730,

	171856,176336,

	

	176272,180848,

	185368,203432,

	196724,202444,

	280540,365084,

	

	308620,389924,

	319550,430402,

	356408,399592,

	437456,455344,

	

	469028,486178

};

int main()

{

	int a, b, i, count;

	//freopen("in.in", "r", stdin);

	//freopen("out.out", "w", stdout);

	while(scanf("%d%d", &a, &b) != EOF)

	{

		for(count=0, i=0; i<28; i++)

			if(a<=fn[i][0]&&fn[i][1]<=b)

				count++;

		printf("%d\n",count);

	} 

	return 0;	

} 

参考答案(时间最优[4]):

#include<stdio.h>

int fn[30][2]={

	220,284,

	1184,1210,

	2620,2924,

	5020,5564,

	

	6232,6368,

	10744,10856,

	12285,14595,

	17296,18416,

	

	63020,76084,

	66928,66992,

	67095,71145,

	69615,87633,

	

	79750,88730,

	100485,124155,

	122265,139815,

	

	122368,123152,

	141664,153176,

	142310,168730,

	171856,176336,

	

	176272,180848,

	185368,203432,

	196724,202444,

	280540,365084,

	

	308620,389924,

	319550,430402,

	356408,399592,

	437456,455344,

	

	469028,486178

};

int main()

{

	int a, b, i, count;

	//freopen("in.in", "r", stdin);

	//freopen("out.out", "w", stdout);

	while(scanf("%d%d", &a, &b) != EOF)

	{

		for(count=0, i=0; i<28; i++)

			if(a<=fn[i][0]&&fn[i][1]<=b)

				count++;

		printf("%d\n",count);

	} 

	return 0;	

} 

题目和答案均来自于互联网,仅供参考,如有问题请联系管理员修改或删除。

退出移动版